aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias P. Braendli <matthias.braendli@mpb.li>2014-02-11 12:33:24 +0100
committerMatthias P. Braendli <matthias.braendli@mpb.li>2014-02-11 12:33:24 +0100
commitd9f6727654cad16951b0e8ca85c1c8e1263421bf (patch)
tree55c902ccf23eabb742d17fcf327dd60186eef029
parentd18555671ab1a18b5385db3996e719c1fc9ae768 (diff)
downloadfdk-aac-0.1.0.tar.gz
fdk-aac-0.1.0.tar.bz2
fdk-aac-0.1.0.zip
try to do a first fdk-aac-dabplus releasev0.1.0
-rw-r--r--ChangeLog24
-rwxr-xr-xbootstrap123
-rw-r--r--configure.ac2
3 files changed, 7 insertions, 142 deletions
diff --git a/ChangeLog b/ChangeLog
index 0702fe0..1676972 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,21 +1,5 @@
-0.1.3
- - Updated upstream sources, with a number of crash fixes and new features
- (including support for encoding 7.1)
+2014-02-11: Matthias P. Braendli <matthias@mpb.li>
+ (v0.1.0):
+ Initial release of fdk-aac-dabplus, based on
+ forked from https://github.com/piratfm/fdk-aac-dabplus
-0.1.2
- - Fix a few more crashes
- - Include dependency libs (such as -lm) in the pkg-config file
-
-0.1.1
- - Updated to a new upstream version from Android 4.2, fixing a lot of crashes
- - Cleanup of autotools usage
- - Make sure the shared library links to libm if necessary
- - Performance improvements on x86
- - Added support for WG4/DVD audio channel mappings
- - Minimized the differences to upstream
- - Added an example encoder tool
-
-0.1.0
- - Initial release of fdk-aac
- - autotools based build system
- - Enable setting VBR bitrate modes
diff --git a/bootstrap b/bootstrap
index 79de673..a3394ab 100755
--- a/bootstrap
+++ b/bootstrap
@@ -1,123 +1,4 @@
#! /bin/sh
-# bootstrap: the ultimate bootstrap/autogen.sh script for autotools projects
-# Copyright (c) 2002, 2003, 2004, 2005, 2006 Sam Hocevar <sam@zoy.org>
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the Do What The Fuck You Want To
-# Public License, Version 2, as published by Sam Hocevar. See
-# http://sam.zoy.org/wtfpl/COPYING for more details.
-#
-# The latest version of this script can be found at the following place:
-# http://sam.zoy.org/autotools/
-
-# Die if an error occurs
-set -e
-
-# Guess whether we are using configure.ac or configure.in
-if test -f configure.ac; then
- conffile="configure.ac"
-elif test -f configure.in; then
- conffile="configure.in"
-else
- echo "$0: could not find configure.ac or configure.in"
- exit 1
-fi
-
-# Check for needed features
-auxdir="`sed -ne 's/^[ \t]*A._CONFIG_AUX_DIR *( *\([^ )]*\).*/\1/p' $conffile`"
-libtool="`grep -q '^[ \t]*A._PROG_LIBTOOL' $conffile && echo yes || echo no`"
-header="`grep -q '^[ \t]*A._CONFIG_HEADER' $conffile && echo yes || echo no`"
-aclocalflags="`sed -ne 's/^[ \t]*ACLOCAL_AMFLAGS[ \t]*=//p' Makefile.am`"
-
-# Check for automake
-amvers="no"
-for v in "-1.11" "111" "-1.10" "110" "-1.9" "19" "-1.8" "18" "-1.7" "17" "-1.6" "16" "-1.5" "15"; do
- if automake${v} --version >/dev/null 2>&1; then
- amvers="${v}"
- break
- fi
-done
-
-if test "${amvers}" = "no" && automake --version > /dev/null 2>&1; then
- amvers="`automake --version | sed -e '1s/[^0-9]*//' -e q`"
- if expr "$amvers" "<" "1.5" > /dev/null 2>&1; then
- amvers="no"
- else
- amvers=""
- fi
-fi
-
-if test "$amvers" = "no"; then
- echo "$0: you need automake version 1.5 or later"
- exit 1
-fi
-
-# Check for autoconf
-acvers="no"
-for v in "" "259" "253"; do
- if autoconf${v} --version >/dev/null 2>&1; then
- acvers="${v}"
- break
- fi
-done
-
-if test "$acvers" = "no"; then
- echo "$0: you need autoconf"
- exit 1
-fi
-
-# Check for libtool
-if test "$libtool" = "yes"; then
- libtoolize="no"
- if glibtoolize --version >/dev/null 2>&1; then
- libtoolize="glibtoolize"
- else
- for v in "16" "15" "" "14"; do
- if libtoolize${v} --version >/dev/null 2>&1; then
- libtoolize="libtoolize${v}"
- break
- fi
- done
- fi
-
- if test "$libtoolize" = "no"; then
- echo "$0: you need libtool"
- exit 1
- fi
-fi
-
-# Remove old cruft
-for x in aclocal.m4 configure config.guess config.log config.sub config.cache config.h.in config.h compile libtool.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 ltmain.sh libtool ltconfig missing mkinstalldirs depcomp install-sh; do rm -f $x autotools/$x; if test -n "$auxdir"; then rm -f "$auxdir/$x"; fi; done
-rm -Rf autom4te.cache
-if test -n "$auxdir"; then
- if test ! -d "$auxdir"; then
- mkdir "$auxdir"
- fi
- aclocalflags="${aclocalflags} -I $auxdir"
-fi
-
-# Explain what we are doing from now
-set -x
-
-# Bootstrap package
-if test "$libtool" = "yes"; then
- ${libtoolize} --copy --force
- if test -n "$auxdir" -a ! "$auxdir" = "." -a -f "ltmain.sh"; then
- echo "$0: working around a minor libtool issue"
- mv ltmain.sh "$auxdir/"
- fi
-fi
-
-aclocal${amvers} ${aclocalflags}
-autoconf${acvers}
-if test "$header" = "yes"; then
- autoheader${acvers}
-fi
-#add --include-deps if you want to bootstrap with any other compiler than gcc
-#automake${amvers} --add-missing --copy --include-deps
-automake${amvers} --foreign --add-missing --copy
-
-# Remove cruft that we no longer want
-rm -Rf autom4te.cache
-
+autoreconf --install && \
+ echo "You can call ./configure now"
diff --git a/configure.ac b/configure.ac
index 04252ce..98f4066 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl -*- Autoconf -*-
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([fdk-aac], [0.1.3], [http://sourceforge.net/projects/opencore-amr/])
+AC_INIT([fdk-aac-dabplus], [0.1.0], [http://opendigitalradio.org/])
AC_CONFIG_AUX_DIR(.)
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([tar-ustar foreign])